Cannot set X-Robots-Tag header on subfolders

I’m trying to set certain paths on our website rasa.com to send an X-Robots-Tag: none header, but so far it’s not working, and I noticed another user here found that the tag seems to be controlled by netlify:
that is, set to "none" on deploy previews, and cleared on production deploys.

Could this be true? I’ve had luck setting it on only one other site, which is assets.rasa.com, but here only by applying it to the root i.e. /*.

Hi, @lunelson. I’m not seeing a header rule for this header on that site. How are you defining the rule (in _headers or netlify.toml)? Can you copy/paste the rule here which isn’t working?