Cannot force Node version for consistent building (Cannot use Node 12.x)

10:38:34 PM: error polv@1.0.0: The engine "node" is incompatible with this module. Expected version "12.x". Got "10.21.0"
10:38:34 PM: error Found incompatible module.

Actually, I wrote .npmrc with engine-strict=true and package.json

  "engines": {
    "node": "12.x",
    "npm": "please-use-yarn",
    "yarn": "1.x"
  }

Hi there, you would set the node version with an .nvmrc file:

1 Like