Cannot add https to the second domain

Hello,

Here is my site address: https://condescending-clarke-12a633.netlify.app/

I have 2 custom domains, hakankaraduman.com.tr and hakan.codes. I have the ssl on the first one, after that I added the second one, it opens the websites when I write it with www, but not without it. Also doesn’t have “netlify dns” badge next to it.

What can I do to solve this? Thanks.

Hey! :wave:

I can see that hakankaraduman.com.tr is working as expected. Can you confirm this too?

You’ll need to add the second domain to https://app.netlify.com/teams/karadumanhakan1/dns.

Then, on this page, https://app.netlify.com/sites/condescending-clarke-12a633/settings/domain, you’ll see that there is additional configuration required for your hakan.codes domain.

This help topic explains it in more detail :+1:

Yes, main domain works correctly, with ssl.

When I open the first url you sent, I see that my second domain is not added there, but added to the second url page you sent. It now is fixed partly, when I added it to the first url you sent.

But now, it only opens with http, it doesn’t have ssl. Will it be updated automatically or am I restricted to a single domain to use ssl? Or should I do something to add ssl?

Hey there!

Yep, it was configured fine. The last step is to ensure that the SSL certificate is renewed. I went ahead and clicked ‘Renew certificate’ and… voila! Your certificate now covers all domains :+1:

I see, I tought it was only for the other domain, glad to know that was for all domains. Thanks a lot for the help. Have a good day.