Can I disable brotli compression?

Hi!

I’m glad brolti compression was recently added, but it prevents my site to work with https://brid.gy/ to cross-post articles from my personal website to twitter.

on https://brid.gy/about#profile-links :

Also, if your web server has Brotli compression enabled, Bridgy won’t work with it due to this long-standing App Engine bug. More background. Until this bug is fixed, we recommend disabling Brotli on your web server as a workaround.

This bug seems to be long standing issue, I don’t see it being resolved any time soon on Google App Engine soon.

It would be great if there was a way to disable brotli compression.

1 Like

hi @jpcaruana - i have checked with the team, and we are aware of that :point_up_2: GH issue - one of our teammates, zach, is one of the commentors, so we are definitely keeping an eye on this.

Unfortunately, there is no way to disable brotli support for an individual site or account. I’m sorry we can’t be more helpful with this.

If I were you, I would add your thoughts to the issue on GitHub. Like with everything, if there are enough people asking for a fix and describing how their work is impacted, it is more likely that the work to solve the underlying problem will get solved. Sorry I don’t have better news for you!