`Callback was already called` - building gatsby site

Hi, I can’t resolve issue with building gatsby site. Since a few days I’m getting following error:

3:17:52 PM: error UNHANDLED EXCEPTION Callback was already called.
3:17:52 PM: 
3:17:52 PM:   Error: Callback was already called.
3:17:52 PM:   
3:17:52 PM:   - async.js:16 throwError
3:17:52 PM:     [repo]/[neo-async]/async.js:16:11
3:17:52 PM:   
3:17:52 PM:   - async.js:2818 
3:17:52 PM:     [repo]/[neo-async]/async.js:2818:7
3:17:52 PM:   
3:17:52 PM:   - next_tick.js:132 _combinedTickCallback
3:17:52 PM:     internal/process/next_tick.js:132:7
3:17:52 PM:   
3:17:52 PM:   - next_tick.js:181 process._tickCallback
3:17:52 PM:     internal/process/next_tick.js:181:clock9 

Package.json

{
  "name": "gatsby-starter-netlify-cms",
  "description": "Example Gatsby, and Netlify CMS project",
  "version": "1.1.3",
  "author": "Austin Green",
  "dependencies": {
    "bulma": "0.7.5",
    "gatsby": "2.17.0",
    "gatsby-image": "2.2.29",
    "gatsby-plugin-disqus": "1.1.4",
    "gatsby-plugin-google-tagmanager": "2.1.15",
    "gatsby-plugin-netlify": "2.1.22",
    "gatsby-plugin-netlify-cms": "3.0.18",
    "gatsby-plugin-offline": "2.2.10",
    "gatsby-plugin-purgecss": "2.4.0",
    "gatsby-plugin-react-helmet": "3.1.13",
    "gatsby-plugin-robots-txt": "1.5.0",
    "gatsby-plugin-sass": "2.1.20",
    "gatsby-plugin-sharp": "2.2.32",
    "gatsby-plugin-sitemap": "2.2.21",
    "gatsby-remark-autolink-headers": "2.1.16",
    "gatsby-remark-copy-linked-files": "2.1.28",
    "gatsby-remark-images": "3.1.28",
    "gatsby-remark-prismjs": "3.3.20",
    "gatsby-remark-relative-images": "^0.2.3",
    "gatsby-source-filesystem": "2.1.33",
    "gatsby-transformer-remark": "2.6.30",
    "gatsby-transformer-sharp": "2.3.0",
    "lodash": "4.17.15",
    "lodash-webpack-plugin": "0.11.4",
    "netlify-cms": "2.9.7",
    "node-sass": "4.12.0",
    "parcel-bundler": "1.12.4",
    "prismjs": "1.17.1",
    "prop-types": "15.7.2",
    "react": "16.10.2",
    "react-dom": "16.10.2",
    "react-helmet": "5.2.1",
    "uuid": "3.3.3"
  },
  "keywords": [
    "gatsby"
  ],
  "license": "MIT",
  "main": "n/a",
  "scripts": {
    "start": "npm run develop",
    "clean": "rimraf .cache public",
    "build": "npm run clean && gatsby build",
    "develop": "npm run clean && gatsby develop",
    "serve": "gatsby serve",
    "format": "prettier --trailing-comma es5 --no-semi --single-quote --write \"{gatsby-*.js,src/**/*.js}\"",
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "devDependencies": {
    "prettier": "1.18.2",
    "rimraf": "2.7.1"
  }
}

Using Node 8.

Full deploy log available here: https://app.netlify.com/sites/gallant-mcnulty-8ac2d3/deploys/5e0a0637af09c64352a2e783

On localhost all works well :thinking:
I tried build site on new netlify instance but I’m getting the same error.

Thanks for any advice.

Cheers

I’m experiencing the same problem. The same build has worked perfectly well earlier, but edited a text change, and then suddenly I got this error message.

I just tested my project on different computer where I’ve not done a npm install in a while. It worked well, until I deleted package-lock.json and node_modules.

hey, all!

Node 8 is entering end-of-life (EOL), so there’s a possibility that this is a compatibility issue with the site expecting Node 10+

I’d recommend trying a branch with a newer version of Node to see if that clears up the issue.

it may also be worth running npm outdated / yarn outdated to see if any of your plugins have gone significantly out-of-date — upgrading those may fix it

hope that helps!

1 Like

I also have this issue, mine stopped working earlier this year. Have anyone figured out any solution to this?

hey @samypogs, did you try upgrading your node version already?

I’m experiencing the same. Updated node to 12.14.1 and ran npm outdated

@G4R4N - did updating node help?

Hi,

I was able to fix this issue be changing
“netlify-cms” ==> “netlify-cms-app”
in the package.json

When running the gatsby build it shows a warning that netlify-cms had been deprecated and we must use netlify-cms-app

Hi, @HinnHabib, welcome to our Netlify community site and thank you so much for sharing the solution you found.

This should be very helpful for anyone searching for this issue and finding this topic. Thanks again for sharing this great information!

Same answer here: https://stackoverflow.com/questions/59575264/building-gatsby-site-on-netlify-err-callback-was-already-called :slight_smile: