Build tools out of date

Hey Netlify,
I just wanted to point out that a lot of your tools are out of date and really do need an upgrade, for example:

  • Yarn - 1.17.0 (netlify) vs 1.24.4 (current) (I’m confident this won’t break any builds)
  • Ubuntu (why is 16.04 the latest option?? 20.04 is much better, and there isn’t even an option for it - or even 18.04)
  • and others

Can we please at least get some kind of way to upgrade these, given that the Yarn upgrade I don’t believe will hurt any builds, as well as the Ubuntu upgrade which might, but that is what the selection in settings is for.

For Yarn specifically, you can set the YARN_VERSION environment variable to get a newer version installed in your build image.

2 Likes

I’d definitely echo @william on the YARN_VERSION.

As for the build image, I’d encourage you to file an issue in our build-image repo:

I’m sure they’d love a PR if you want to work on Ubuntu 18.04++ support!