Build script Build script returned non-zero exit code: 3

Hello,

I am having trouble deploying one of my sites and I cannot understand what is wrong from the logs.
All I see is this hint: “Build script returned non-zero exit code: 3”

Anyone knows how to debug this issue?

Hi @yonatan! Welcome to netlify community.

If you search the forum, you will find several posts dealing with this issue:

Site deploy failed Deploying and Building

i am trying to deploy my website and i am getting build failed error: 3:06:23 PM: Error running command: Build script returned non-zero exit code: 1 3:06:23 PM: Failing build: Failed to build site 3:06:23 PM: failed during stage ‘building site’: Build script returned non-zero exit code: 1 { “name”: “adevonx”, “version”: “1.0.0”, “description”: "Application Development Operation ", “main”: “server.js”, “scripts”: { “start”: "./node_modules/.bin/netlify-lambda serve ", “build”: “./node…

Error running command: Build script returned non-zero exit code: 1 Deploying and Building

Briefly summarize the issues you have been experiencing. When trying to deploy my site for the first time, I’m receiving the error “Error running command: Build script returned non-zero exit code: 1” Please provide a link to your live site hosted on Netlify Site is not live for this reason, but here is a link to my latest build attempt: https://app.netlify.com/sites/latise/deploys/5d1a479ed3745c2a940f3e0b & here is a link to my project on github: https://github.com/brianalauren/latise What…

Build failing with non-zero exit code 1 Deploying and Building

Briefly summarize the issues you have been experiencing. Hey all wave, while building, I get non-zero exit code 1 while webpack is processing some lodash modules from node_modules. Weird because I have a project using an identical webpack/babel config that builds without issues on Netlify. https://app.netlify.com/sites/typvp/deploys/5d262a830a052f0008008ff8 Please provide a link to your live site hosted on Netlify https://typvp.netlify.com What have you tried as far as troubleshooting goe…

And there is also this general debugging guide as well:

[Common Issue] Debugging site builds Deploying and Building

Note: This article is only about builds within Netlify’s Continuous Integration (CI) environment, as triggered from git commits or from incoming build webhooks. You can learn more in depth about how Netlify builds your site in this article about how our build bots build sites. Some background There are a fair number of reasons that a build could fail in Netlify’s CI environment, even if building works locally. Testing locally is always the place to start, and the thing we will recommend to you …

Go ahead and work through those, and let us know if the error persists - we’ll be happy to help if you tell us what you tried :+1:

Hi,
I saw these posts but none of them were refering to exit code 3.

I ended up deleting the site and setting it up again from scratch and the problem went away.

Cheers,

Yonatan

1 Like