Build keeps failing when fetching from github

This has build been consistently failing at the same point. And for for along time, previously in another team.

It seems more likely to happen late in UK afternoon which I’m guessing is likely to be peak US time. The rebuild without any cache always works. I suspect a timeout as the repo has many submodules and a LOT of code.

4:11:56 PM: Build ready to start
4:11:59 PM: build-image version: 53b83b6bede2920f236b25b6f5a95334320dc849
4:11:59 PM: build-image tag: v3.6.0
4:11:59 PM: buildbot version: a706ec7a557bcc28584843816a376a10c08955ca
4:11:59 PM: Fetching cached dependencies
4:11:59 PM: Starting to download cache of 707.9MB
4:12:06 PM: Finished downloading cache in 7.296737137s
4:12:06 PM: Starting to extract cache
4:12:20 PM: Finished extracting cache in 14.263183363s
4:12:21 PM: Finished fetching cache in 22.419969071s
4:12:21 PM: Starting to prepare the repo for build
4:12:22 PM: Preparing Git Reference refs/heads/master
4:12:31 PM: Error fetching branch: https://github.com/w3c/wai-website refs/heads/master
4:12:31 PM: Failing build: Failed to prepare repo
4:12:31 PM: Failed during stage 'preparing repo': exit status 1
4:12:31 PM: Finished processing build request in 32.058087231s

If you have a lot of code, maybe it’s GitHub that’s rate limiting or something on your repo? That’s my guess. I don’t even know if it really does that.

But whenever you get this error, would you try cloning the repo yourself to see if it’s happening for your computer too and not just Netlify? It would help narrow down the cause.

OK will do. But please note that the error never happens when not using cache from previous deploy

That’s really strange. I hope a support member gets to this thread soon enough as they might have a better idea of why this would happen.

2 Likes

hi @slim, is this problem still occurring? i am going to try and get some :eyes: on this if yes.