Branch deployed site is note secure

Hi,

I’ve enabled branch deploy for the www branch in GitHub. I can hit the www site, but it is not secure. How do I turn on HTTPS or is there a better way to get www added to my URL than branch deploy?

Thank you,
Thomas

hi thomas, welcome to community.

we’ll need quite a bit more information before we can help you. See this post for some guidelines :slight_smile:

Hi Perry and thanks for responding.

Specifically what I want to do is have my site accessible when someone types “www” before it.

In setting the site name via settings/general the site I enter “mysite” and mysite.netflify.com is created and I’d like to be able to use www.mysite.netlify.com as well.

I tried adding the domain www.mysite.netlify.com via settings/domain/setup and I get the message “A site can only have one Netlify address”

After further research, I found branch deploys via “settings/deploys” so I created a “www” branch in GitHub and enabled “Let me add individual branches”. From that, I can now hit www.mysite.netlify.com however, it is not secure - I get the message “Your connection to this site is not secure”

The short version is I’d like to be able to use add “www” so I can use www.mysite.netlify.com but can’t quite get there. It is currently working from a branch deploy, but is not HTTPS enabled. How can I turn that on?

Or maybe there is a better approach than using branch deploy?

It is entirely possible that I don’t know enough to ask the right questions, so please let me know what further details you might need to help me resolve this.

Thank you for your help!

Hi @thomas

Since mysite.netlify.com is already a subdomain of netlify.com, what you are trying to do won’t work, unfortunately. It’s not possible to add a www subdomain to a netlify subdomain. Our wildcard SSL certificate does not support that, and our platform does not support dots in the subdomain name.

You’ll need to add a custom domain to your site in order to have a www subdomain.

1 Like