Auto publish from Gitlab not working

Hi there, I have a blog setup on Netlify and I use Gitlab cloud to host the repository. As far as I can tell I have everything setup correctly but my site won’t auto-publish when I commit to the repository. I know the setup is okay since manual publishing works fine. Is there some Gitlab setting that could disable the trigger for a deploy? Any suggestions would be appreciated.

Jason

Our automatic deploys are triggered by a webhook that we put in place when you link the repo via our UI, at GitLab. You should be able to see one pointing to the URL https://api.netlify.com/hooks/gitlab in your Repo’s Settings->Integrations page in the GitLab UI. If you do see it there:

image

…you can click into it (choose “Edit”) to see a history of sends and how our service responded. If you do see it there and there are some errors, try sharing them here!

If you don’t see it there, may be useful to re-link the repo by:

  1. selecting the ‘edit settings’ button from the repository settings card, which you can find at the top of the build & deploy settings page in our UI
  2. choosing ‘link to a different repository’ link that then appears
  3. linking to the same repo
  4. let us know how it goes!

Ugh, reconnecting it worked. I should have just tried that initially. Thanks!

2 Likes