API Error in backend

I’m getting this error in my Netlify CMS backend: https://monosnap.com/file/n0sTKp90ftoFwfauGQ1Flandu02wl7

When I set a breakpoint, I see this: https://take.ms/wsRwB

I suspect it’s because my config is not correct: https://github.com/uplinkhq/website/blob/master/source/admin/config.yml

What’s happening in the CMS UI when this error occurs? Stuck at login?

No, login through Identity with GitHub as the external provider works fine!
I can’t see any collection items though, which I posted about on SO today: https://stackoverflow.com/questions/56343619/netlify-cms-nested-yaml-using-middleman

I guess something cannot be loaded from GitHub, judging by the error message and “documentation_url”.

Is there a way to find out what exactly that is?

What kinds of files are they, markdown with frontmatter?

Added an answer on SO: https://stackoverflow.com/questions/56343619/netlify-cms-nested-yaml-using-middleman/56431037#56431037

Thanks, @erquhart, setting the extension solved it! :smiley:

But nesting the attributes under the locale in the YML files doesn’t work, I had to change them to “de.title” and “en.title”. Is there a way to use nested attributes in this case?

The API_ERROR still happens though:

https://take.ms/IqWLz
https://take.ms/Vm3F2

Anything I can do about that?

@manuelmeurer I noticed the source/images/uploads/ folder you set in your config doesn’t exist in your repo

1 Like

@tomrutgers Brilliant, that fixed it! :smiley:

I added a .gitkeep file to create the folder, now it shows up in the media view: https://take.ms/ftn4X
Wouldn’t it make sense to ignore dotfiles there?

Agreed. Would you mind opening an issue here?

1 Like

Done: https://github.com/netlify/netlify-cms/issues/2370

3 Likes