Analytics Issues: Data is being collected, but not displayed in the UI

Hi everyone,

as some of you have noticed, our service is currently experiencing issues with Analytics that show up in a couple of different ways:

  • sites where Analytics was activated for the first time since May 26 2020 are not seeing any data displayed in the UI
  • some sites where Analytics has been running problem free before May 26th 2020 are now not displaying new data
  • high traffic sites are seeing intermittent problems - data is failing to display

Data is being collected, but it is not being displayed correctly. No data loss has occurred.

We are aware of the cause of the problem(s) and we have engineers actively working on a fix to remediate the situation. This is a top priority for us, and we are working as hard as we can to resolve it. We are hoping to have a fix in place at some point next week. We will update this timeline as we make more progress in working towards a fix.

We understand that this is a very frustrating situation and one that may be impacting you and your business negatively. This kind of thing is never the experience we want you to have.

Anyone who wishes to migrate off the Analytics service due to these issues, and who can’t wait for a fix, should get in touch with us here or by visiting netlify.com/support and choosing “billing” from the dropdown menu, which will put you through to the billing helpdesk, and we will issue you a refund.

We’ll update here as soon as we have more information on this - thank you for your patience. If you have questions, please let us know below.

6 Likes

Thanks for looking into it! Please keep us updated on this.

1 Like

Is it me? Or is already working? Because I can see further than the 26th…

Thank you for the help guys!

1 Like

Hi everyone,

The team pulled together and we did a lot of heavy lifting on this overnight as we know this is affecting so many of you.

We have fixed the cause of the error, and, as @michael-andreuzza noted, Analytics should now be correctly displaying the data we have been collecting (as mentioned above, no data was lost, it was just a display/parse issue.) :partying_face:

If you are seeing stuck analytics, or incomplete/stale data, please let us know right away by commenting on this thread and mentioning your netlify site name, and we will look in to it.

We are monitoring the situation closely on our side too.

Thank you for your patience, and we’re sorry this service hasn’t been the positive experience you were hoping for.

6 Likes

Thank you so much, that was a quick one.

no problem, michael-andreuzza. Please do let us know if you (or anyone else) sees any lingering issues.

Looks good! Thanks for putting the work in! Please let the team know we are grateful for the quick fix. :heart_eyes:

2 Likes

will do, fabsh! glad it is working now for you.

Thanks so much all! Analytics are working great!

1 Like

I enabled analytics quite a few hours ago on my website and no data is showing up. It is still saying that it’s backfilling historic data. How long is it supposed to take? Website: priceless-pasteur-20100a

Hey @yasoob,

This can take a day of two, particularly if there’s a lot of data to backfill. However, given the recent outage and remediation, it could take longer. Please do write back tomorrow if the situation hasn’t improved!

Hi - is this still the right place for reporting analytics data not being displayed? My site is vibrant-haibt-75f25f. No updates showing for the past 5 hours.

Kind regards,

hi @Dreamworks,

we are not aware of any issues with Analytics a this time - the issue described in this thread was a temporary one we have since fixed, yay!

I am seeing some pageviews from today (august 5th) on your site, are you still seeing something stuck?

Hi Perry - it stopped for about 7 hours yesterday, but restarted and backfilled again last night. Thanks for following up.

great! glad it is working now.