Admin 'not found' using Netlify CMS Starter

Hi Team

I installed the coffee site Netlify CMS starter template to get a feel for things, but my admin seems to be ‘not found’.

I changed my site name from the default, to karm-development.netlify.com but when I try login, it accepts my credentials and then just shows a yellow ‘not found’ message at the top of the screen.

can someone assist?

thank you :slight_smile:

Hi @markusflint and welcome to the community :slight_smile:
Do you mind sharing the browser network traffic when you try the login?
Specifically, go to http://karm-development.netlify.com/admin, open browser dev tools, go to network tab, do a full page refresh, then initial the logic process.

Any log errors/warnings can help too.

Thanks

Like so @erez ?

Yes! Can you show the full requests and responses for the lasts 4 requests (the ‘settings’ ones and the ones returning 404).
Also can you share your config.yml content?

settings

// response
age: 0
alt-svc: clear
content-encoding: gzip
content-length: 77
content-type: application/json
date: Wed, 19 Feb 2020 11:08:45 GMT
server: Netlify
status: 200
vary: Origin,Accept-Encoding
via: 1.1 google
x-nf-request-id: 0667fdca-af74-43e1-af75-a6b4b128453e-5662635
// request
:authority: karm-development.netlify.com
:method: GET
:path: /.netlify/git/settings
:scheme: https
accept: */*
accept-encoding: gzip, deflate, br
accept-language: en-US,en;q=0.9,fr;q=0.8,it;q=0.7,nb;q=0.6
authorization: Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1ODIxMTI5NDQsInN1YiI6ImQwNWFmODE2LThkMGUtNDU4ZS05OWE3LTU3ZmRhYTc2ZWVjZSIsImVtYWlsIjoibWFya0B5ZWxsb3ctbGxhbWEuY29tIiwiYXBwX21ldGFkYXRhIjp7InByb3ZpZGVyIjoiZW1haWwifSwidXNlcl9tZXRhZGF0YSI6eyJmdWxsX25hbWUiOiJtYXJrdXNmbGludCJ9fQ.H-DBiXcMpDgfVs-V5b8xbP-fU1sIdILVLlxQA_NlQeQ
cache-control: no-cache
cookie: nf_jwt=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1ODIxMTI5NDQsInN1YiI6ImQwNWFmODE2LThkMGUtNDU4ZS05OWE3LTU3ZmRhYTc2ZWVjZSIsImVtYWlsIjoibWFya0B5ZWxsb3ctbGxhbWEuY29tIiwiYXBwX21ldGFkYXRhIjp7InByb3ZpZGVyIjoiZW1haWwifSwidXNlcl9tZXRhZGF0YSI6eyJmdWxsX25hbWUiOiJtYXJrdXNmbGludCJ9fQ.H-DBiXcMpDgfVs-V5b8xbP-fU1sIdILVLlxQA_NlQeQ
pragma: no-cache
referer: https://karm-development.netlify.com/admin/
sec-ch-ua: "Google Chrome 79"
sec-fetch-dest: empty
sec-fetch-mode: cors
sec-fetch-site: same-origin
user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36

first master error

// response
access-control-expose-headers: ETag, Link, Location, Retry-After, X-GitHub-OTP, X-RateLimit-Limit, X-RateLimit-Remaining, X-RateLimit-Reset, X-OAuth-Scopes, X-Accepted-OAuth-Scopes, X-Poll-Interval, X-GitHub-Media-Type
age: 1
alt-svc: clear
content-encoding: gzip
content-length: 121
content-security-policy: default-src 'none'
content-type: application/json; charset=utf-8
date: Wed, 19 Feb 2020 11:08:46 GMT
referrer-policy: origin-when-cross-origin, strict-origin-when-cross-origin
server: Netlify
status: 404
strict-transport-security: max-age=31536000; includeSubdomains; preload
vary: Origin,Accept-Encoding,Accept,X-Requested-With
via: 1.1 google
x-accepted-oauth-scopes: 
x-content-type-options: nosniff
x-frame-options: deny
x-github-media-type: github.v3; format=json
x-github-request-id: 910E:7B53:E6EB15:1B5751E:5E4D173A
x-nf-request-id: 0667fdca-af74-43e1-af75-a6b4b128453e-5662767
x-oauth-client-id: 0eef2fa971fd9f7d46a2
x-oauth-scopes: public_repo, repo:status, user:email
x-ratelimit-limit: 5000
x-ratelimit-remaining: 4996
x-ratelimit-reset: 1582112953
x-xss-protection: 1; mode=block

// request
:authority: karm-development.netlify.com
:method: GET
:path: /.netlify/git/github/branches/master?ts=1582110525768
:scheme: https
accept: */*
accept-encoding: gzip, deflate, br
accept-language: en-US,en;q=0.9,fr;q=0.8,it;q=0.7,nb;q=0.6
authorization: Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1ODIxMTI5NDQsInN1YiI6ImQwNWFmODE2LThkMGUtNDU4ZS05OWE3LTU3ZmRhYTc2ZWVjZSIsImVtYWlsIjoibWFya0B5ZWxsb3ctbGxhbWEuY29tIiwiYXBwX21ldGFkYXRhIjp7InByb3ZpZGVyIjoiZW1haWwifSwidXNlcl9tZXRhZGF0YSI6eyJmdWxsX25hbWUiOiJtYXJrdXNmbGludCJ9fQ.H-DBiXcMpDgfVs-V5b8xbP-fU1sIdILVLlxQA_NlQeQ
cache-control: no-cache
content-type: application/json; charset=utf-8
cookie: nf_jwt=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1ODIxMTI5NDQsInN1YiI6ImQwNWFmODE2LThkMGUtNDU4ZS05OWE3LTU3ZmRhYTc2ZWVjZSIsImVtYWlsIjoibWFya0B5ZWxsb3ctbGxhbWEuY29tIiwiYXBwX21ldGFkYXRhIjp7InByb3ZpZGVyIjoiZW1haWwifSwidXNlcl9tZXRhZGF0YSI6eyJmdWxsX25hbWUiOiJtYXJrdXNmbGludCJ9fQ.H-DBiXcMpDgfVs-V5b8xbP-fU1sIdILVLlxQA_NlQeQ
pragma: no-cache
referer: https://karm-development.netlify.com/admin/
sec-ch-ua: "Google Chrome 79"
sec-fetch-dest: empty
sec-fetch-mode: cors
sec-fetch-site: same-origin
user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
ts: 1582110525768

second master error

// response
access-control-expose-headers: ETag, Link, Location, Retry-After, X-GitHub-OTP, X-RateLimit-Limit, X-RateLimit-Remaining, X-RateLimit-Reset, X-OAuth-Scopes, X-Accepted-OAuth-Scopes, X-Poll-Interval, X-GitHub-Media-Type
age: 0
alt-svc: clear
content-encoding: gzip
content-length: 121
content-security-policy: default-src 'none'
content-type: application/json; charset=utf-8
date: Wed, 19 Feb 2020 11:08:47 GMT
referrer-policy: origin-when-cross-origin, strict-origin-when-cross-origin
server: Netlify
status: 404
strict-transport-security: max-age=31536000; includeSubdomains; preload
vary: Origin,Accept-Encoding,Accept,X-Requested-With
via: 1.1 google
x-accepted-oauth-scopes: 
x-content-type-options: nosniff
x-frame-options: deny
x-github-media-type: github.v3; format=json
x-github-request-id: BD04:5F09:8BC1C9:117D18C:5E4D1739
x-nf-request-id: 0667fdca-af74-43e1-af75-a6b4b128453e-5663162
x-oauth-client-id: 0eef2fa971fd9f7d46a2
x-oauth-scopes: public_repo, repo:status, user:email
x-ratelimit-limit: 5000
x-ratelimit-remaining: 4995
x-ratelimit-reset: 1582112953
x-xss-protection: 1; mode=block

// request
:authority: karm-development.netlify.com
:method: GET
:path: /.netlify/git/github/branches/master?ts=1582110526963
:scheme: https
accept: */*
accept-encoding: gzip, deflate, br
accept-language: en-US,en;q=0.9,fr;q=0.8,it;q=0.7,nb;q=0.6
authorization: Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1ODIxMTI5NDQsInN1YiI6ImQwNWFmODE2LThkMGUtNDU4ZS05OWE3LTU3ZmRhYTc2ZWVjZSIsImVtYWlsIjoibWFya0B5ZWxsb3ctbGxhbWEuY29tIiwiYXBwX21ldGFkYXRhIjp7InByb3ZpZGVyIjoiZW1haWwifSwidXNlcl9tZXRhZGF0YSI6eyJmdWxsX25hbWUiOiJtYXJrdXNmbGludCJ9fQ.H-DBiXcMpDgfVs-V5b8xbP-fU1sIdILVLlxQA_NlQeQ
cache-control: no-cache
content-type: application/json; charset=utf-8
cookie: nf_jwt=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE1ODIxMTI5NDQsInN1YiI6ImQwNWFmODE2LThkMGUtNDU4ZS05OWE3LTU3ZmRhYTc2ZWVjZSIsImVtYWlsIjoibWFya0B5ZWxsb3ctbGxhbWEuY29tIiwiYXBwX21ldGFkYXRhIjp7InByb3ZpZGVyIjoiZW1haWwifSwidXNlcl9tZXRhZGF0YSI6eyJmdWxsX25hbWUiOiJtYXJrdXNmbGludCJ9fQ.H-DBiXcMpDgfVs-V5b8xbP-fU1sIdILVLlxQA_NlQeQ
pragma: no-cache
referer: https://karm-development.netlify.com/admin/
sec-ch-ua: "Google Chrome 79"
sec-fetch-dest: empty
sec-fetch-mode: cors
sec-fetch-site: same-origin
user-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
ts: 1582110526963

config file is unchanged from the starter repo

backend:
    name: git-gateway
    branch: master
    commit_messages:
        create: "Create {{collection}} “{{slug}}”"
        update: "Update {{collection}} “{{slug}}”"
        delete: "Delete {{collection}} “{{slug}}”"
        uploadMedia: "[skip ci] Upload “{{path}}”"
        deleteMedia: "[skip ci] Delete “{{path}}”"

media_folder: static/img
public_folder: /img

... collections etc.

i’ve tried twice to leave my comment here with all the logs you requested, but it keeps saying my comment is too similar to an existing comment, but i dont have an existing comment like it?

Can you try posting it on our slack https://www.netlifycms.org/chat #help channel?

thanks! logging in :slight_smile:

Problem was, I had set my repo to private after the access tokens had been created. I went to the Settings -> Identity section, and recreated the access token’s to my repo.

Sorted :white_check_mark:

Thanks @erez :facepunch:t2:

1 Like