Add `framework = "gatsby"` to [dev] section of your netlify.toml to avoid th

I got this message from Netlify dev:
Add framework = "gatsby" to [dev] section of your netlify.toml to avoid this selection prompt next time

But when I added:
[dev] framework = "gatsby"

to my netlify.toml file I got an error message of:

Error: Unsupported value provided for "framework" option in config

Am I formatting my netlify.toml file incorrectly? How do I format it?

Did you use the search before posting?
What about reading through our https://community.netlify.com/search?q=common%20issue?

howdy! we are currently working on this, actually!

this is the PR to watch: https://github.com/netlify/cli/pull/843

1 Like