A Record to Load Balancer IP resulting in DNS_PROBE_FINISHED_NXDOMAIN after 24hrs

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example: gifted-antelope-58b104.netlify.app
    https://theworkingwoman.netlify.app/

  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
    The domain is learnir.org

  • Build problems? Link or paste the FULL build log & build settings screenshot

The better the post - the faster the answer.

I use the Namecheap DNS to route to Netlify load balancer IP using the A record.

I don’t know where to diagnose it from, I tried the debugging tools.
Seems to be that the domain is not been routed to the Load Balancer, either way, I also don
t super understand the responses in tools such as:
https://dnsviz.net/d/learnir.org/dnssec/

Please help me understand it, and what to do with my current situation.

Hello @henry212,

https://dnsviz.net/d/learnir.org/dnssec/ shows DNSSEC errors which are due to your PRIOR (before netlify) DNS host having enabled DNSSEC for you and not disabled it.

You should be able to get in touch with their tech support to have them disable it for you, and then you’ll see NO errors on that https://dnsviz.net/d/learnir.org/dnssec/ site (I also don’t understand them fully - but I know they are symptoms of that root cause, and that the fix has to come from the old DNS host).

I’ve sent a few hundred customers to their former DNS host to get this fixed and all managed to - and most are not DNS experts, so I guess this is a frequent tech support request to most DNS hosts who support DNSSEC (we don’t, so there is no way to fix from our side).

It resolved itself. It probably needed more than 24hrs to do so. It’s now working well after waiting for 30hrs max