404 when submitting form

Hi, on the site elp.netlify.com/contact I’m getting a 404 error each time I try to submit the form…even as I’ve followed all recommendations at this link [Common Issue] Form problems, form debugging, 404 when submitting and used Netlify Forms on two other sites without any problem.

For your reference, the following files show my implementation:

  1. https://gitlab.com/k16e/elp_v1/blob/master/src/assets/js/FormActions.js
  2. https://gitlab.com/k16e/elp_v1/blob/master/src/components/partials/ContactForm.vue

Thank you for helping out.

So, that’s the behavior…404, but the .then() runs obviously because the “Thank you” message is displayed.

@k16e, to troubleshoot this the two key details needed are:

  • a link to the form at the site itself
  • a link to the HTML version of the form if the form is generated or submitted by javascript

Would you please send us those two links/URLs?

Thank you, @luke. Here’s the details you’ve asked for:

  1. https://elp.netlify.com/contact

  2. Ah, no, the links, they’re already shared in my question post, aren’t they?

Thanks.

let’s back up a little bit!

Using the search, there are a couple of people who are using forms with vue and maybe experiencing the same problem you are:

is that applicable, here?

Was there a solution there? Let me visit that one? Thanks.

For all the docs and refs, I can see anything I’m doing wrong with my code. Except someone can help me cross-check. But, this 404 thing on submission just won’t go away and then no submission is received at the Netlify end. Can someone test it here at https://elp.netlify.com/contact? Thanks.

hi there,

i just tested it and it seems to work fine.

can you see if you received a message from jane@johnson.com in your dashboard?

Please do note that our spam fighting robots don’t allow obvious test submissions “test@test.com” through to cut down on the amount of spam you receive.

@perry The form is failing in the background, the network monitor throws a 404.

1 Like

So, no, there was no submission from jane@johnson.com no submission coming in at all…

Hi, @perry and @tomrutgers and @luke, am I out of luck here?

hey @k16e - we took a look at this, and dug around a bit, and unfortunately, nothing obvious stuck out, we were unable to understand why its not working. I know that’s probably not what you want to hear.

The only thing I’d might suggest is that it could be an issue with how the ssg is set up.

are you able to make html based forms work?

1 Like

The reason I’m flabbergasted by this is this is the…I’m using about the same setup as from other Gridsome/Vue site where Netlify Forms works like a charm. I so far have NF on 3 other sites and have had no problem with them at all!

do you have a link to a working form?

i’m assuming you’ve been comparing code between working and not working - each form has a distinct name?